EOSERV Forum > Client Editing > Everything invisible
Page: << 1 >>
Everything invisible
Author Message
Post #204633 Everything invisible

Hey guys... I got a strange bug happening and I can't figure out what's the cause. 
Sometimes after killing an npc all player chars and npcs disappear... 

Is this related to the client? Windows 10? Eoserv? 

it's very weird as it sometimes happens all the time and sometimes not at all... 

Please help.

Thank you and happy holidays! 

22 weeks, 5 days ago
Post #204634 Re: Everything invisible

This is my fault! I believe it's either to do with the AOE spells/weapons or something I changed in the NPC Killed function to support pets!

If you can try pin point the issue I'll fix it! I'm also gonna run some tests!

---
https://Havenshost.net/web-hosting.php   - Free 5GB web host
22 weeks, 5 days ago
Post #204635 Re: Everything invisible

Your client is trying to render some graphic that doesn't exist, probably. Likely causes include:

1. Invalid npcs being spawned on the map (Nonexistent NPC ID or a nonexistent icon/gfx ID)
2. Invalid effect being played on the map (Nonexistent GFX ID)
3. Invalid item ID in inventory or paperdoll (Nonexistent item ID or a nonexistent icon/gfx ID)

---
Want to learn to pixel?
Pixelsource.org
22 weeks, 5 days ago
Post #204637 Re: Everything invisible

Well its hard to pinpoit the problem I don't think its pub or gfx related because it happens on chars with nothing and maps with on 1 npc type spawn.

It's very much like I said, sometimes after killing an npc everything goes invis, what triggers it is an npc kill, that's the only thing I know for sure.

Just today this happened:  start client, go to map, kill npc, everything goes invis.

Close client, set it to run as win vista service pack 2, launch, same map, kill npc. everything good.

Close client, set back to run as win 10 normally, launch, same map, kill npc. everything good...

It's very odd.. 

And @callum I think this started when u fixed the Eoserv rev that had ranged line aoe... idk if u remember. *edited I tested the game with the orignal eoserv 0.7.0 and it worked fine, so your rev is causing the problem



22 weeks, 5 days ago
Page: << 1 >>

EOSERV Forum > Client Editing > Everything invisible