EOSERV Forum > Announcements > EOSERV 0.3.1 and WebCP 2
Topic is locked.
Page: << 1 2 3 4 >>
EOSERV 0.3.1 and WebCP 2
Author Message
Post #850 EOSERV 0.3.1 and WebCP 2

You will have to wipe and reinstall your database to install this over 0.2.0.

You should copy changes from the new config.ini to install this over 0.2.0. (LogOut, LogErr, PasswordSalt)

EOSERV 0.2.0 -> 0.3.1 changes:

  • Password hashing
  • Server no longer instantly closes (with the debug executable) but waits for a user to press enter
  • Optional logging stdout and stderr to files. (stderr piped to error.log by default)
  • Inventory, Drop, pick up and junk items.
  • Paperdoll, Equip/unequip items.
  • Sit/stand
  • Warp to different maps (with admin command only)

WebCP 1 -> 2 changes:

  • GM tools section (view and search all accounts/characters)
  • Edit details/password

Current problems: (to fix before next version)

  • EOSERV: Doesn't handle well equipping items when you have over 16.7 million of them. (Is this even fixable?)
  • WebCP: Only shows 100 users on each page now (until pagination is added)
  • EOSERV: Server doesn't seem to survive more than a couple of hours... (Linux only? Due to build up of CLOSE_WAIT sockets?)
  • EOSERV: Bah, warping somewhere makes the items disappear, need to f12 to get them to show.
  • EOSERV: 2 slot equipment (ring, bracer etc.) have some problems still
  • EOSERV: No range checking on drops, no existance checking on paperdoll removal (you can uneqip the 0s)
  • EOSERV: Can drop lore item
  • EOSERV: Should only send paperdoll when you change a viewable item
  • EOSERV: No "auto-refresh" if the client or server detects either is out-of-sync
  • EOSERV: Apparently name validation doesn't work since someone made the name Vult-r
  • EOSERV: And you can't create new accounts? Goddamnit. I need to test more before releases. (Fixed in 0.3.1)

Admin commands: (see admin.ini to change access levels)

  • $kick username
  • $warp map x y  ($warp 5 40 40)  NOTE: Warping to one of these maps will make your character inpossible to log in to: 0, 80, 81, 185, 223, 264, 271, 272, 276
  • $warpmeto user ($warpmeto Sausage)
  • $warptome user ($warptome Sausage)
  • $sitem id [amt] ($sitem 200 1)

Todo: (for next version)

  • WebCP: HGM Edit/delete characters/accounts
  • WebCP: Show inventory/paperdoll information
  • EOSERV: Read map file format
  • EOSERV: Open/Close doors
  • EOSERV: Warp to other maps
  • EOSERV: Timer system
  • EOSERV+WebCP: Get online count from WebCP connection
  • EOSERV: Limit to one session per account

10 years, 11 weeks ago
Post #852 Re: EOSERV 0.3.0 and WebCP 2

awsome cant wait to try it.

10 years, 11 weeks ago
Post #854 Re: EOSERV 0.3.0 and WebCP 2

Nice job Sausage ! :D

10 years, 11 weeks ago
Post #856 Re: EOSERV 0.3.0 and WebCP 2

Creating accounts dosent work...

10 years, 11 weeks ago
Post #861 Re: EOSERV 0.3.0 and WebCP 2

Register is closed, or not working ? :) Can i have acc for testing ?
10 years, 11 weeks ago
Post #870 Re: EOSERV 0.3.0 and WebCP 2
Shizmo posted: (16th Mar 2009 06:40 pm)


Register is closed, or not working ? :) Can i have acc for testing ?
Hey noob!

This is a server for download... and the regrestration isnt working...

10 years, 11 weeks ago
Post #873 Re: EOSERV 0.3.0 and WebCP 2
I have the same problem. When i click on create, then nothing happens...
10 years, 11 weeks ago
Post #874 Re: EOSERV 0.3.0 and WebCP 2

account creation isnt working When you manually create an account it does not work either.

10 years, 11 weeks ago
Post #876 Re: EOSERV 0.3.0 and WebCP 2

i made the private server with a lil bit of problems and i need to start over i tried to redownload the programs to make a new account on mySQL and stuff but it didnt work help


BTW NICE JOB SAUSAGE KEEP IT UP MAN!!!!! WOOTWOOT
10 years, 11 weeks ago
Post #877 Re: EOSERV 0.3.0 and WebCP 2
xsepx posted: (16th Mar 2009 08:48 pm)

account creation isnt working When you manually create an account it does not work either.


Exaktly my point!:D
10 years, 11 weeks ago
Post #879 Re: EOSERV 0.3.0 and WebCP 2

The password hashing is interfering with the login i think.

10 years, 11 weeks ago
Post #910 Re: EOSERV 0.3.0 and WebCP 2

Didn't realise account creation was broken, I'll fix it and release 0.3.1 when I get home :P.

I need to test shit before I release it.

10 years, 11 weeks ago
Post #913 Re: EOSERV 0.3.0 and WebCP 2

thanks/
10 years, 11 weeks ago
Post #930 Re: EOSERV 0.3.0 and WebCP 2
Sausage posted: (17th Mar 2009 12:37 am)

Didn't realise account creation was broken, I'll fix it and release 0.3.1 when I get home :P.

I need to test shit before I release it.


Good job sausage! You did it under a half day :D But it still dosent work :( Now it just not giving the regip any valeu...
10 years, 11 weeks ago
Post #931 Re: EOSERV 0.3.1 and WebCP 2

u released 0.3.1, but its still not working, it says its creating it, then when its done, it gives u the message that tells u to login but stays at the create screen except ur name is no longer there, and when u go to login, u get the same error as b4 the account or password doesnt exist in the database

10 years, 11 weeks ago
Page: << 1 2 3 4 >>
Topic is locked.
EOSERV Forum > Announcements > EOSERV 0.3.1 and WebCP 2